题目简介:
读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。
输入格式:
每个测试输入包含 1 个测试用例,格式为
1 2 3 4 5
| 第 1 行:正整数 n 第 2 行:第 1 个学生的姓名 学号 成绩 第 3 行:第 2 个学生的姓名 学号 成绩 ... ... ... 第 n+1 行:第 n 个学生的姓名 学号 成绩
|
其中姓名
和学号
均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。
输出格式:
对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。
输入样例:
1 2 3 4
| 3 Joe Math990112 89 Mike CS991301 100 Mary EE990830 95
|
输出样例:
1 2
| Mike CS991301 Joe Math990112
|
思路:
自定义快排即可
tip:
代码如下:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
| #include <iostream> #include <string> #include <vector> #include <algorithm>
using namespace std;
bool cmp(vector<string>& s1, vector<string>& s2) {
return atoi(s1[2].c_str()) > atoi(s2[2].c_str()); }
int main() {
int n; cin >> n; vector<vector<string>> student(n);
for (int i = 0; i < n; i++) {
string name, num, grade;
cin >> name >> num >> grade;
student[i].push_back(name); student[i].push_back(num); student[i].push_back(grade); }
sort(student.begin(), student.end(), cmp);
cout << student[0][0] << " " << student[0][1] << endl; cout << student[n - 1][0] << " " << student[n - 1][1]; }
|